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chapter 1

Introduction to Satellite Link
The Digidesign® Satellite Link option lets you 
link up to 5 Pro Tools® systems (or up to 4 
Pro Tools systems and an Avid® Media Com-
poser® or Video Satellite LE system) over an 
Ethernet network so that you can cue, play, and 
stop the transports, make play selections, and 
solo tracks across any of the systems from any 
linked workstation.

From each linked Pro Tools system, Satellite 
Link lets you link and unlink networked systems 
and see the link status of other connected sys-
tems.

By setting Satellite Link preferences, you can 
configure those Pro Tools systems for single- or 
multi-operator workflows.

Satellite Link can be used simultaneously with 
Digidesign MachineControl™. Satellite Link al-
lows one linked Pro Tools system to go online 
and drive a 9-pin capable device. 

On systems with a D-Control® console, Satellite 
Link can work in conjunction with D-Control 
Multi-mode, allowing you to operate the trans-
port of any of the networked Pro Tools systems 
from the D-Control Transport section. 

Video Satellite LE provides limited Satellite 
Link features. For more information on using 
Satellite Link with Video Satellite LE, see the 
Video Satellite LE Guide.
System Requirements and 
Compatibility Information
Satellite Link requires a Digidesign-qualified 
Pro Tools|HD® system running Pro Tools 8.0 or 
higher. 

Each satellite Pro Tools system must have an 
iLok authorization for the Satellite Link option 
and have an Ethernet connection to a Local Area 
Network (LAN). The administrator Pro Tools 
system does not require an iLok authorization.

In addition, each Pro Tools system in a Satellite 
Link network must be resolved to a common 
video reference, or “house sync,” using a Digide-
sign SYNC HD™ or SYNC I/O™. 

To use Media Composer with Satellite Link, Me-
dia Composer 3.1 with the Video Satellite op-
tion is required. 

Compatibility Information

Digidesign can only assure compatibility and 
provide support for hardware and software it has 
tested and approved. 

For complete system requirements and a list of 
Digidesign-qualified computers, operating 
systems, hard drives, and third-party devices, 
refer to the latest information on the Digidesign 
website:

www.digidesign.com/compatibility
Chapter 1: Introduction to Satellite Link 1
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Digidesign Registration
Review the enclosed Digidesign Registration 
Information Card and follow the instructions 
on it to quickly register your purchase online. 
Registering your purchase is the only way you 
can be eligible to receive complimentary techni-
cal support and future upgrade offers. This is 
one of the most important steps you can take as 
a new user. 

About This Guide
This guide describes features of the Satellite Link 
option. For complete instructions on connect-
ing and configuring your Pro Tools|HD system, 
see the HD Setup Guide. 

For additional information about using 
Pro Tools software, see the Pro Tools Reference 
Guide.
Satellite Link Guide
Conventions Used in This Guide

Digidesign guides use the following conven-
tions to indicate menu choices and key 
commands:
:

The names of Commands, Options, and Settings 
that appear on-screen are in a different font.

The following symbols are used to highlight 
important information:

Convention Action

File > Save Choose Save from the File 
menu

Control+N Hold down the Control key 
and press the N key

Control-click Hold down the Control key 
and click the mouse button

Right-click Click with the right mouse 
button

User Tips are helpful hints for getting the 
most from your system.

Important Notices include information that 
could affect your data or the performance of 
your system.

Shortcuts show you useful keyboard or 
mouse shortcuts.

Cross References point to related sections in 
this guide and other Digidesign guides.



About www.digidesign.com
The Digidesign website (www.digidesign.com) is 
your best online source for information to help 
you get the most out of your Pro Tools system. 
The following are just a few of the services and 
features available. 

Product Registration Register your purchase 
online. See the enclosed Digidesign Registration 
Information Card for instructions. 

Support and Downloads Contact Digidesign 
Technical Support or Customer Service; down-
load software updates and the latest online 
manuals; browse the Compatibility documents 
for system requirements; search the online An-
swerbase; or join the worldwide Pro Tools com-
munity on the Digidesign User Conference. 

Training and Education Study on your own using 
courses available online or find out how you can 
learn in a classroom setting at a certified 
Pro Tools training center. 

Products and Developers Learn about Digidesign 
products; download demo software or learn 
about our Development Partners and their plug-
ins, applications, and hardware. 

News and Events Get the latest news from 
Digidesign or sign up for a Pro Tools demo.

Pro Tools Accelerated Videos Watch the series of 
free tutorial videos. Accelerated Videos are de-
signed to help you get up and running with 
Pro Tools and its plug-ins.
Chapter 1: Introduction to Satellite Link 3
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chapter 2

Installing Satellite Link
Network Connections
Satellite Link requires all linked systems to be 
connected to an Ethernet Local Area Network. 
All systems should be on the same subnet, and it 
is recommended that all systems be on the same 
Ethernet switch, in order to minimize response 
time over the network. 

Installing Satellite Link 
Software
You need to install the Satellite Link option on 
each system that you want to use as a satellite. 
You do not need to install Satellite Link on the 
system that you want to use as the administrator 
system. 

To install Satellite Link software:

1  Insert the Satellite Link Installer disc into your 
computer. 

2  Double-click the Satellite Link installer appli-
cation. 

3  Follow the on-screen instructions to complete 
the installation.

4  When installation is complete, click Finish 
(Windows) or Close (Mac).
Authorizing Satellite Link
Satellite Link is authorized using the iLok 
USB Smart Key (iLok), manufactured by PACE 
Anti-Piracy, Inc.

The iLok is similar to a dongle, but unlike a don-
gle, it is designed to securely authorize multiple 
software applications from a variety of software 
developers. 

This key can hold over 100 licenses for all of 
your iLok-enabled software. Once an iLok is au-
thorized for a given piece of software, you can 
use the iLok to authorize that software on any 
computer.

iLok USB Smart Key

The iLok USB Smart Key is not supplied with 
your plug-in or software option. You can use 
the one included with your Pro Tools|HD 
system, or purchase one separately.
Chapter 2: Installing Satellite Link 5
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To authorize Satellite Link:

1  If you do not have an iLok.com account, visit 
www.iLok.com and sign up for an iLok.com ac-
count.

2  Transfer the license for Satellite Link to your 
iLok.com account by doing the following:

• Visit http://secure.digidesign.com/activation.

• Enter your Activation Code (listed on your 
Activation Card) and your iLok.com User 
ID. Your iLok.com User ID is the name you 
create for your iLok.com account.

3  Transfer the licenses from your iLok.com ac-
count to your iLok USB Smart Key by doing the 
following:

• Insert the iLok into an available USB port 
on your computer.

• Go to www.iLok.com and log in.

• Follow the on-screen instructions for trans-
ferring your licences to your iLok.

4  Launch Pro Tools.

5  If you have any installed unauthorized 
plug-ins or other software options, you will be 
prompted to authorize them. Follow the 
on-screen instructions to complete the authori-
zation process.

For information about iLok technology and 
licenses, see the iLok Usage Guide.
Satellite Link Guide
Uninstalling Satellite Link
If you need to uninstall the Satellite Link option 
from your system, follow the instructions below 
for your computer platform.

Mac OS X

To uninstall an option:

1  Open the Pro Tools folder on your Startup 
drive (Applications/Digidesign).

2  Drag the option to the Trash and empty the 
Trash.

Windows XP

To uninstall an option:

1  Choose Start > Control Panel.

2  Double-click Add or Remove Programs.

3  Select the oprion from the list of installed ap-
plications.

4  Click Remove.

5  Follow the on-screen instructions to remove 
the option.

Windows Vista

To uninstall an option:

1  Choose Control Panel.

2  Under Programs, click Uninstall a Program.

3  Select the oprion from the list of installed ap-
plications.

4  Click Uninstall.

5  Follow the on-screen instructions to remove 
the option.
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Using Satellite Link
Configuring Satellite Link

Configuring Network Settings

Satellite Link systems communicate over Ether-
net Local Area Networks. You can configure the 
network settings on each Pro Tools system to 
build one or more Satellite Link networks on the 
same LAN. 

Ethernet Interface

On computers with multiple Ethernet inter-
faces, you can select the interface you want to 
use for Satellite Link communications.

To select the Ethernet interface for Satellite Link:

1  Choose Setup > Peripherals and click Satellites.

2  Under Advanced Network Settings, choose the 
Ethernet interface from the Interface pop-up 
menu. 

3  Click OK.
TCP/UDP Port

Systems in a Satellite Link network need to use 
the same TCP/UDP port to communicate. Avail-
able satellite systems will only appear on other 
satellite systems using the same port.

By default, Satellite Link uses TCP/UDP port 
28282. 

If the default port is already in use, or if you 
want to set up separate Satellite Link networks, 
you can select a different TCP/UDP port for Sat-
ellite Link communication.

To select the TCP/UDP port for Satellite Link 
communication:

1  Choose Setup > Peripherals and click Satellites.

2  Under Advanced Network Settings, enter the 
TCP/UDP port number you want the system to 
use.

3  Click OK.
Chapter 3: Using Satellite Link 7
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Configuring a Satellite Link 
Network

To set up Pro Tools systems or Video Satellite LE 
for Satellite Link operation, one Pro Tools sys-
tem on the network must be designated an ad-
ministrator system. 

Other systems on the network are set up as sat-
ellite systems, then they are added to the net-
work from the administrator system. 

Configuring Satellite Systems

Do the following for each Pro Tools system you 
want to configure as a Satellite Link satellite:

1  Choose Setup > Peripherals and click Satellites.

2  In the System Name text box, enter a name for 
the system.

3  Under Mode, choose Satellite.

4  Click OK.

Configuring a satellite in the Satellites page of the 
Peripherals dialog
Satellite Link Guide
To configure a Media Composer system as a Video 
Satellite:

1  In Media Composer, choose Edit > Preferences.

2  In the Project window, click the Settings Tab 
and double-click Video Satellite.

3  In the Video Satellite Settings window, select 
Video Satellite Mode. 

4  Click OK.

To set up a Video Satellite LE system as a 
satellite:

1  On the Pro Tools LE system, choose Setup > 
Peripherals and click Satellites.

2  In the System Name text box, enter a name for 
the system.

3  Under Mode, choose Enable Satellite Mode.

4  Click OK.

Configuring a Video Satellite LE system in the Satellites 
page of the Peripherals dialog



Configuring an Administrator System

If a Pro Tools system does not have the Satellite 
Link option installed, it can only operate as an 
administrator. You can, however, change a sat-
ellite system to an administrator system.

To configure a Pro Tools system as a Satellite Link 
administrator:

1  Choose Setup > Peripherals and click Satellites.

2  In the System Name text box, enter a name for 
the system.

3  Under Mode, choose Administrator.

4  Under Administrator, choose the current sys-
tem from the System 1 pop-up menu. 

5  Click OK.

Configuring the Administrator system in the Satellites 
page of the Peripherals dialog
Adding Satellites to the Network

When systems have been configured as satel-
lites, they become available on the administra-
tor system. The satellite systems are then de-
clared from the Administrator system to build 
the Satellite Link network.

To declare satellite systems:

1  On the administrator system, choose Setup > 
Peripherals and click Satellites.

2  Under Administrator, declare the systems you 
want to use as satellites from the System 2-5 
pop-up menus. 

3  Click OK.

Systems 1-5 appear, in order, from left to right, 
in the Synchronization section of the Transport 
window.

Declared satellites in the in the Satellites page of the 
Peripherals dialog

Declared satellites in the in the Synchronization section 
of the Transport window
Chapter 3: Using Satellite Link 9
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Linking Satellite Systems
When a Pro Tools system has been declared as a 
satellite, it can then be placed in a linked state 
from the local machine or from another satel-
lite. When a system is linked, the following fea-
tures/commands can be controlled across all 
linked systems:

• Linking and unlinking of the system

• Transport controls (Stop, Play, FF, Rew)

• Play selections

• Scrub/Shuttle location

• Channel solo (including Solo clear)

• Clearing system errors (e.g., DAE errors)

Satellite Link Controls

When a Pro Tools system has been declared as a 
satellite, the following Satellite Link controls ap-
pear in the Transport window: 

Link Button Controls the link status of the local 
system.

Satellite Link Buttons Control the link status of 
the other satellite systems. On every system, one 
of these buttons corresponds to that system’s 
main Link button.

Link buttons highlight to indicate linked status.
Satellite Link Guide
To display Satellite Link controls in the Transport 
window:

Choose View > Transport > Synchronization and 
View > Transport > Expanded.

To link or unlink the local Pro Tools system:

Click the Link button in the Transport win-
dow. 

To link or unlink other satellite systems:

Click the corresponding Satellite Link button 
in the Transport window.

To link or unlink all declared satellite systems:

Alt-click (Windows) or Option-click (Mac) the 
Link button or a Satellite Link button in the 
Transport window.

Linking Systems During Playback

You can link or unlink a system while it or any 
other linked system is playing back (“join in 
play”), and the transports will play in sync. In 
cases where both systems are playing back, the 
newly linked system will cue to the location of 
the system on which the link was initiated. 

Satellite Link controls in the Transport window

Link button

Satellite Link buttons



Linking Play Selections

You can set linked Pro Tools systems to transmit 
and receive play selections from other satellite 
systems. This lets you configure your setup to se-
lectively mirror Edit window selections between 
systems, or to have all systems mirror Edit win-
dow selections on all other systems. 

If you are working in a multi-user dub stage 
environment where dialog, FX, and music reside 
on different systems, it can be useful to set those 
systems to only transmit play selections, and set 
the recorder/video Pro Tools system to only re-
ceive play selections.

If you are working in a single-user mix envi-
ronment and are moving between systems, it 
can be useful to set all systems to transmit and 
receive play selections, so that you can work 
with the same selection on any system.

To set satellite Pro Tools systems to mirror play 
selections on other satellite systems

1  On the systems where you will be making play 
selections, do the following:

• Choose Setup > Preferences and click Syn-
chronization. 

– and –

• In the Satellites section of the Synchroniza-
tion page, select the Transmit Play Selections 
option.

2  On the systems that you want to mirror the 
play selections, do the following:

• Choose Setup > Preferences and click Syn-
chronization. 

– and –

• In the Satellites section of the Synchroniza-
tion page, select the Receive Play Selections 
option.

3  Make sure the systems are linked.
Solo Linking

You can set linked Pro Tools systems to transmit 
the solo status of their tracks and receive solo 
status information from other satellite systems. 

If you are working in a multi-user dub stage 
environment where dialog, FX, and music reside 
on different systems, it can be useful to set those 
systems to send and receive solos, and set the re-
corder/video Pro Tools system so that it does not 
transmit or receive solos. 

If you are working in a single-user mix envi-
ronment and are moving between systems, it 
might be useful to set all systems to transmit 
and receive solos, so that solos propagate across 
all systems.

Solo Safe When Solo Linking is enabled, tracks 
on all systems retain their Solo Safe status.

Solo Clear When Solo Linking is enabled, a Solo 
Clear operation (Option+Solo) clears all solos on 
systems set to receive solos. 

To set satellite Pro Tools systems to transmit or 
receive solo status:

1  On the systems that you want to solo tracks, 
do the following:

• Choose Setup > Preferences and click Syn-
chronization. 

– and –

• In the Satellites section of the Synchroniza-
tion page, select the Transmit Solos option. 

2  On the systems where you want tracks to fol-
low solo behavior for solos on other systems, do 
the following:

• Choose Setup > Preferences and click Syn-
chronization. 

– and –

• In the Satellites section of the Synchroniza-
tion page, select the Receive Solos option.
Chapter 3: Using Satellite Link 11
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3  Make sure the systems are linked.

Using Solo Link without Linking 
Transport Controls

If you are synchronizing multiple Pro Tools sys-
tems to an external synchronizer, you can still 
take advantage of the Solo Link feature. 

You can set a satellite Pro Tools system to always 
send its solo status, whether linked or unlinked, 
so you can solo tracks across systems without 
linking transport controls. 

To set a satellite Pro Tools system to always solo 
even when it is not linked:

1  Choose Setup > Preferences and click Synchro-
nization. 

2  In the Satellites section of the Synchroniza-
tion page, select the Solo Independent of Linked 
State option.

Solo Link Behavior in the Solo Modes

Solo in Place With Solo Link, when using Solo 
In Place, the mode of solo operation is deter-
mined by the system transmitting the solo.

If a linked system is in Solo Latch mode, solo-
ing a track on that system adds to the number of 
tracks in solo, regardless of the solo mode of 
other systems set to receive solos.

If a linked system is in Solo X-OR mode, solo-
ing a track on that system cancels all other sys-
tem’s solos regardless of the solo mode of other 
systems set to receive solos.

AFL and PFL Modes With Solo Link, AFL and PFL 
solos on a linked system have no effect on other 
systems.

An AFL-soloed track on a linked system can be 
muted by a Solo In Place on another system. To 
avoid this, use PFL instead of AFL. 
Satellite Link Guide
Satellite Link Operation 

Clearing Errors on Linked Systems

By default, linked systems will continue to oper-
ate if one of the systems experiences an error 
and its transport stops. Any error message on a 
linked system appears in the tool tip for the cor-
responding Satellite Link button in the Trans-
port window.

You can set each system to stop playback when 
it experiences an error. 

To clear an error dialog on a linked system:

In the Transport window on another linked 
system, Shift-click the Satellite Link button for 
the affected system. 

To set a linked system to stop the transport on all 
systems when an error occurs:

Make sure the DAE Errors Stop All Linked Sys-
tems option is selected in the Synchronization 
Preferences.

To set all systems to stop the transport when an 
error occurs, make sure this option is selected on 
all linked systems.

Playback and Modal Dialogs

Linked systems will stop playback (or prevent 
playback from starting) if a modal dialog (such 
as the I/O Setup, Hardware Setup, or Playback 
Engine dialog) is opened on any linked system. 

To avoid interrupting playback on another 
system when opening a modal dialog, 
unlink the system before opening the dialog.



Using Satellite Link with 
MachineControl
MachineControl Deck Control Mode can be 
used to operate a 9-pin synchronization device 
(such as a Soundmaster ATOM or a CB Electron-
ics 9-Pin synchronizer), allowing Pro Tools to 
act as a “code only master” for systems con-
trolled by the synchronizer.

Satellite Link lets you use MachineControl on 
one linked Pro Tools system at a time.

When one linked Pro Tools system is already 
online and you go online with another linked 
Pro Tools system, Satellite Link will automati-
cally take the first system offliine.

Any linked Pro Tools systems set to 
“Transport=Pro Tools” will follow Satellite Link 
transport commands. 

Any linked Pro Tools systems set to “Trans-
port=Machine” cannot transmit Satellite link 
transport commands, but will follow Satellite 
Link transport commands if they are offline. 

Control Surface Support for 
Satellite Link

Linking Satellite Systems
(D-Control, D-Command and C|24)

To link or unlink the local Pro Tools system:

Hold Control (Windows) or Command (Mac) 
and press the Pro Tools Online switch in the 
Transport section. 
Satellite Link Soft Keys
(D-Control and D-Command)

To link or unlink other satellite systems:

1  Hold Control and press the Modes switch in 
the Automation Soft Keys section.

2  Press the Soft Key that corresponds to the 
name of the system that you want to link or un-
link. 

The Soft Key lights solid to indicate that the cor-
responding system is linked, and flashes to indi-
cate that the corresponding system is displaying 
an error. 

To link or unlink all declared satellite systems:

Hold Alt+Control (Windows) or 
Option+Command (Mac) and press the Pro Tools 
Online switch in the Transport section.

To toggle the solo transmit status of the local 
Pro Tools system:

1  Hold Control and press the Modes switch in 
the Automation Soft Keys section.

2  Press the Soft Key that corresponds to 
“Transmit Solo.”

The Soft Key lights solid to indicate that trans-
mit solo is enabled.
Chapter 3: Using Satellite Link 13
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